This wiki has been archived and can only be read.

Galactic Civilizations II

From Cedega Wiki
Jump to: navigation, search


Game Info

<tbody> </tbody>
Game version 1.0
Installer See Issues
Game Not Working
Patch 1.40X
Download patch Through SDCentral (Propietary Tool), or http://www.galciv2.com/Downloads.aspx
Demo works Not Working
Download demo http://www.download.com/Galactic-Civilizations-II-Dread-Lords-demo/3000-7493_4-10518894.html
Requires no-cd patch Activation through Serial Key. No additional CD protection.
Multiplayer works No Multiplayer implemented
Works with Cedega version(s) None
Tested with Cedega version(s) 5.2.10, 5.2.4, 5.1.4, 5.1, 5.0.3
Supported by TransGaming No
URLs http://www.galciv2.com/

Issues

  • Installer:

Propietary SDCentral for gc2 installation is required: A no go issue for cedega as explorer.exe is needed which will be altered through Active-X for SDCentral.

  • Installer on the retail disc works.
  • Running the game after install work around will ultimatley lead to crash on universe creation.

Work around and remaining Problems:

  • Installation:
1.Install under Win 
2.mount win partition
3.copy Stardock directory to a cedega c_drive/Program Files/
  • Running:

Accessed directly over cedega (it brings the former point2play screen up) the game will notice that the SID does not match. deleting SID.bin will result in a grey window. (This window would ask for serial key input, but is not usable.)

First try Solution: Swith to win98 version emulation in properties. This gets the information that Active X was not detected. The intro is displayed, but the game crashes on main-menue access.

Second try Solution: go to gc2 directory over shell and run

GalCiv2 # cedega -use-pthreads yes GalCiv2.exe


the game displays the intro, loads main menue the fonts are resolved. Right, in 5.2.4 cedega all used directx 9.0c True Type font text is OK. I can go in options, create a new game. Everything is like as expected. Create a new game works in 1.3beta2 until entering the galaxy to make your first turn. There currrently our expedition will end:

cedega 5.2.4 debug output:

mmtime pid=13768 tid=13783 
wine: Unhandled exception, starting debugger...
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 10 (X_UnmapWindow)
Resource id in failed request: 0x300003a
Serial number of failed request: 387
Current serial number in output stream: 388

and galciv2 debug.err information:


dindin GalCiv2 # cat debug.err
Debug Message: Version v1.3 beta 2 last updated on: Mon Aug 7 16:26:47 2006
Debug Message: Can't find TGN or GalCiv2 serial number.
Debug Message: *********DXDiag info follows.*********
System Info
Time: 8/8/2006, 22:59:36
DirectX Version: DirectX 9.0c (4.09.0000.0904)
Machine Name: dinu
Operating System: Windows 98 (4.10, Build 1999) A
Languages: English (Regional Setting: English)
System Manufacturer: n/a
System Model: n/a
BIOS: n/a
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4800+, MMX, 3DNow (2 CPUs), ~2.4GHz
Physical Memory: 2012MB RAM
Page File: 0MB used, 494MB available
Windows Dir: C:\WINDOWS
 
 
Display Info
Display device 1:
Device Name: X11
Card Name: X 11 Windowing System
Manufacturer:
Chip Type:
DAC Type:
Key Device: Enum\
Display Memory:
Current Display Mode: 1280 x 1024 (32 bit) (75Hz)
Monitor Name: X 11 Windowing System
Monitor Max Resolution:
Driver Name:
Driver Version:
Driver Date:
DirectX Acceleration Enabled: Yes
 
Your video drivers may be too old to run Galactic Civilizations 2 properly. Installed video drivers must    support Microsoft DirectX 9.0c, which means you should try to have a driver from at least 2005 installed.
 
Please visit the website for your computer manufacturer or video card for more recent drivers.

Your computer manufacturer was reported to be n/a.
Your video card manufacturer was reported to be .
Reported driver date:


Sound info
Sound device 1:
Description: Default Playback Device
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID:
Manufacturer ID:
Product ID:
Driver Name:
Provider:
Driver Version:
Driver Date:
Type:
Other Drivers:
Acceleration Level: 0
Cap Flags: 0
Min/Max Sample Rate: 0, 0
 

Debug Message: *********END dxdiag info.*********
Debug Message: Entering WinMain
Debug Message: ******* Starting Game Shell *******
Debug Message: Going Fullscreen
Debug Message: Preparing to change display settings.
Debug Message: Using multilsample setting: D3DMULTISAMPLE_NONE
Debug Message: Game Resolution: 1280 x 1024
Debug Message: Running fullscreen.
Debug Message: HAL (sw vp): Direct3D HAL
Debug Message: D3DPRESENT_INTERVAL_DEFAULT
Debug Message: Refresh rate: 60
Debug Message: Bit Depth: 32 bit.
Debug Message: *********Checking D3DDevice Caps***********************
Debug Message: A full-color cursor is supported in hardware at high resolution modes.
Debug Message: RGB in format 6:6:6, Masks reported as ff0000:ff00:ff
Debug Message: Now Fullscreen
Debug Message: Shell initialization complete
Debug Message: ***** Initializing Game *****
Debug Message: Timer Frequency is 0 241097
Debug Message: Initializing sound card.
Debug Message: initailizing bink
Debug Message: Create setup screens.
Debug Message: Clear galaxy settings.
Debug Message: Clear influence.
Debug Message: Clear up laws.
Debug Message: Clear first time events.
Debug Message: Clear wonders and trade goods.
Debug Message: Clear sector mapper.
Debug Message: Set mouse.
Debug Message: Set update timer.
Debug Message: Clear data definitions.
Debug Message: No files found matching mask C:\My Documents\My Games\GalCiv2\ships\*.xml
Debug Message: Reading Star Names
Debug Message: Reading Star Names... Done
Debug Message: No files found matching mask D:\.cedega\Civ4\c_drive\Program Files\Stardock\TotalGaming\GalCiv2\Mods\Default\Data\CustomMaps\*.gc2map
Debug Message: No files found matching mask D:\.cedega\Civ4\c_drive\Program  Files\Stardock\TotalGaming\GalCiv2\Mods\Default\Data\Scenarios\*.gc2scenario
Debug Message: Creating Galaxy
Debug Message: Killing threads.
Debug Message: Kiling civs.
Debug Message: Killing ships.
Debug Message: Killing rallypoints.
Debug Message: Killing misc objects.
Debug Message: Killing stars.
Debug Message: Killing anomalies.
Debug Message: Killing space resources.
Debug Message: Killing colonies and planets.
Debug Message: killing scenario.
Debug Message: Clearing Turn Event Log
Debug Message: Clear galaxy settings.
Debug Message: Clear influence.
Debug Message: Clear up laws.
Debug Message: Clear first time events.
Debug Message: Clear wonders and trade goods.
Debug Message: Clear sector mapper.
Debug Message: Galaxy Size Set: 3 x 3
Debug Message: Creating Random Map
Debug Message: Creating Random Map... Stars
Debug Message: Number of Unplaced Stars: 1.
Debug Message: Creating Random Map... Planets
Debug Message: *************** Failed To Place Planet ***************
Debug Message: Creating Random Map... Anomalies
Debug Message: Num Anomalies: 28
Debug Message: Creating Random Map... Resources
Debug Message: Creating Random Map... Done
Debug Message: Setting Game Options
Debug Message: Creating Civs
Debug Message: Drengin Empire: Intellence -> 15
Debug Message: Altarian Republic: Intellence -> 30
Debug Message: Arcean Empire: Intellence -> 30
Debug Message: Torian Confederation: Intellence -> 30
Debug Message: Yor Collective: Intellence -> 30
Debug Message: Creating Civs... Done
Debug Message: Updating ZOC.
Debug Message: Updating ZOC.
Debug Message: Galaxy Create... Done
Debug Message: UIBeginGame called with g_ulLocalPlayerID = 0
Debug Message: UIBeginGameHelper: New Game Started
Debug Message: UIBeginGameHelper: Mods are Disabled


but it looks already promising.

System Specs:

See above

Linux Specs:

* media-video/nvidia-glx
Latest version available: 1.0.8762
Latest version installed: 1.0.8762
Size of files: 31,677 kB
Homepage: http://www.nvidia.com/
Description: NVIDIA X11 driver and GLX libraries
License: NVIDIA
* media-video/nvidia-kernel
Latest version available: 1.0.8762-r1
Latest version installed: 1.0.8762-r1
Size of files: 22,460 kB
Homepage: http://www.nvidia.com/
Description: Linux kernel module for the NVIDIA X11 driver
License: NVIDIA
Linux dindin 2.6.15-gentoo-r7 #4 SMP PREEMPT Thu Mar 16 01:35:32 CET 2006 x86_64 AMD Athlon(tm) 64 X2  Dual Core Processor 4800+ GNU/Linux

make.conf:

CFLAGS="-march=k8 -O2 -msse3 -pipe -fweb -ffast-math -frename-registers"
CHOST="x86_64-pc-linux-gnu"
CXXFLAGS="${CFLAGS} -fvisibility-inlines-hidden"
MAKEOPTS="-j3"
FEATURES="ccache"
LDFLAGS="-Wl,-O1 -Wl,-Bdirect -Wl,-hashvals -Wl,-zdynsort"

tried to switch off / change all VIDEO settings in GC2 options. The problem remains currently. Either the graphic driver or cedega have currently still an issue, or my particular glibc/make.conf/64bit system configuration (which is in this case a private computer and not a test-rig) which is why a behavior confirmation from another party would be helpful.

Personal tools
Namespaces

Variants
Actions
Navigation
Game lists
Resources
Tools